Como instalar PHP 5.4, PHP 5.5, PHP 5.6 en Centos 7

Aquí te enseñamos a instalar las versiones de PHP 5.4 / 5.5 / 5.6 en el sistema operativo Linux Centos 7.

Primero se debe instalar los repositorios EPEL, con el siguiente comando. Si ya tienes el repositorio no es necesario ejecutarlo.

yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

Luego debes ejecutar el siguiente comando para instalar las dependencias REMI, que es donde estan los paquetes de PHP en las versiones requeridas:

rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-7.rpm

Finalmente instalar los paquetes de php con el siguiente comando:

yum install php php-common php-cli php-pdo php-xml

Se instalará la version más antigua disponible en las dependencias disponibles, pero también podrías instalar una versión especifica como se muestra en los siguientes comandos:

yum install php-5.5
yum install php-cli-5.5
yum install php-common-5.5
yum install php-pdo-5.5
yum install php-xml-5.5

Espero te ayude esta información, nos vemos pronto!!

Abrir chat
1
Hola!
En que podemos ayudarte?
Escríbenos sin ningún compromiso :)